Forum

Battery pack makes popping noise and doesn't work  

  RSS

Dave Clarke
(@dave-clarke)
New Member
Joined:1 month  ago
Posts: 1
24/01/2018 8:49 pm  

Hi,

I purchased a replacement BMS for one the got wet and fried.  I replaced one wire at a time and went over each cell circuit with a volt meter and all is good.  It has 58 volts at the discharge wires, but when I plug it into the bike it starts popping in a bad way.

Do you have any idea whats going on?

Thanks

Dave


ReplyQuote
Micah (Vruzend Rep)
(@admin)
Street cred = 5 Ah Admin
Joined:11 months  ago
Posts: 272
29/01/2018 3:56 am  

Is the popping just one pop right when you connect the battery connector to your controller connector? Or is it repeated popping that goes on after everything is connected?

The first one is normal and is called in-rush current. That's your capacitors in your controller charging up instantly and drawing large current out of the battery resulting in a spark at the connector the instant it touches. Lookup "anti spark connector" or "anti spark resistor" to find ways to avoid this.

If its the second case, then it sounds like a poor connection problem that is intermittently making connection.


ReplyQuote
garolittle
(@garolittle)
Street cred = 500 mAh
Joined:5 months  ago
Posts: 50
04/02/2018 12:45 pm  
Posted by: Micah (Vruzend Rep)

Is the popping just one pop right when you connect the battery connector to your controller connector? Or is it repeated popping that goes on after everything is connected?

The first one is normal and is called in-rush current.

I have this all the time.  I was wondering what that was.  So I learned something new today.  : - )


ReplyQuote
  
Working

Please Login or Register